Skip to main content
VulnerabilityPublished

CVE-2026-8201: MongoDB Server · Use After Free

Affects MongoDB ServerSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.1 Medium · fixed in 8.3.2 : update MongoDB Server when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
6.1Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 2% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 8.3.2, 8.2.9, 8.0.23 +1
CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:N/VC:L/VI:L/VA:H/SC:L/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade MongoDB Server to 8.3.2, 8.2.9, 8.0.23 or 7.0.34.

Affected software

ProductAffectedFixed in
MongoDB, Inc.MongoDB ServerAffected
  • >=8.3 <8.3.2
Fixed in
  • 8.3.2
MongoDB, Inc.MongoDB ServerAffected
  • >=8.2 <8.2.9
Fixed in
  • 8.2.9
MongoDB, Inc.MongoDB ServerAffected
  • >=8.0 <8.0.23
Fixed in
  • 8.0.23
MongoDB, Inc.MongoDB ServerAffected
  • >=7.0 <7.0.34
Fixed in
  • 7.0.34

AI-suggested

No specific temporary mitigations or workarounds are documented at this time.

Description

A use-after-free vulnerability exists in MongoDB's Field-Level Encryption (FLE) query analysis component, affecting client-side uses of mongocryptd and crypt_shared. Triggering this vulnerability requires control over the structure of a client's FLE-related query. This issue impacts MongoDB Server’s mongocryptd component v7.0 versions prior to 7.0.34, v8.0 versions prior to 8.0.23, v8.2 versions prior to 8.2.9 and v8.3 versions prior to 8.3.2.

References

Community reviews

Loading reviews…