Skip to main content
VulnerabilityPublished

CVE-2026-8087: OSGeo gdal · Heap-based Buffer Overflow

Affects OSGeo gdalSource CVE Database V5

0
Compare

Public exploit available · CVSS 4.8 Medium.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
4.8Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 12% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
OSGeogdalAffected
  • =3.13.0dev-4
Fixed in–

CPE configurations (1)

  • cpe:2.3:a:osgeo:gdal:*:*:*:*:*:*:*:*

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade the affected OSGeo gdal component to version 3.13.0RC1 or later, which includes the patch identified by commit 184f77dbcc74118c062c05e464c88161d3c37b9b. This is the official fix addressing the vulnerability. No alternative mitigations are indicated by the vendor advisory.

Description

CVE-2026-8087 is a heap-based buffer overflow vulnerability in the OSGeo gdal library up to version 3.13.0dev-4. The flaw exists in the GDnentries function within the file frmts/hdf4/hdf-eos/GDapi.c and can be triggered by manipulating the DataFieldName argument. Exploitation requires local access and no user interaction. A public exploit is available. Upgrading to version 3.13.0RC1 is recommended to address this issue.

References

Community reviews

Loading reviews…