Skip to main content
VulnerabilityPublished Updated

CVE-2026-82310: Apache Airflow FAB provider · Insufficient Session Expiration

Affects Apache Airflow FAB providerSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.2 High : upgrade to 3.9.0 soon.

Data as of 31 Oct 2026, 08:20 UTC

CVSS 3.1 base score
7.2High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.0% chance of exploitation in 30 days – higher than 62% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.9.0
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade Apache Airflow FAB provider and apache-airflow-providers-fab to 3.9.0.

Affected software

ProductAffectedFixed in
Apache Software FoundationApache Airflow FAB providerAffected
  • >=2.0.0 <3.9.0
Fixed in
  • 3.9.0
PyPIapache-airflow-providers-fabpkg:pypi/apache-airflow-providers-fabOther threatsAffected
  • >=2.0.0 <3.9.0
Fixed in
  • 3.9.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade apache-airflow-providers-fab to version 3.9.0 or later, which implements token rejection for deactivated accounts. This official fix effectively mitigates the vulnerability by ensuring tokens for disabled accounts cannot be used or renewed. No additional action is required beyond applying this upgrade.

Description

CVE-2026-82310 is a vulnerability in the Apache Airflow FAB provider where deactivating a user account does not invalidate previously issued tokens. Although password authentication blocks disabled accounts, the Core API continues to accept existing unexpired tokens and allows them to mint replacements, enabling continued access with the original roles. This affects deployments using Airflow 3 with FAB auth manager and Core API token authentication. Upgrading to version 3.9.0 or later mitigates the issue by rejecting tokens for deactivated accounts.

References

Community reviews

Loading reviews…