Skip to main content
VulnerabilityPublished Updated

CVE-2026-86462: Apache Airflow FAB provider · Insufficient Session Expiration

Affects Apache Airflow FAB providerSource CVE Database V5

0
Compare

Mentioned vulnerabilities

Not known to be exploited · CVSS 9.1 Critical : upgrade to 3.9.0 as a priority.

Data as of 31 Oct 2026, 08:20 UTC

CVSS 3.1 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.8% chance of exploitation in 30 days – higher than 57% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.9.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade Apache Airflow FAB provider and apache-airflow-providers-fab to 3.9.0.

Affected software

ProductAffectedFixed in
Apache Software FoundationApache Airflow FAB providerAffected
  • >=3.2.0 <3.9.0
Fixed in
  • 3.9.0
PyPIapache-airflow-providers-fabpkg:pypi/apache-airflow-providers-fabOther threatsAffected
  • >=3.2.0 <3.9.0
Fixed in
  • 3.9.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade apache-airflow-providers-fab to version 3.9.0 or later, which contains the fix for this vulnerability. Deployments that have already applied the fix for CVE-2026-82311 must also upgrade to address this independent session invalidation issue. No other mitigation is indicated by the vendor advisory.

Description

Apache Airflow FAB provider versions 3.2.0 through 3.8.x have a vulnerability where changing a user's password via the Admin user-edit PATCH endpoint does not invalidate existing database-backed sessions. This allows an attacker with a stolen session cookie to maintain access even after the password is changed. The issue affects deployments using the FAB auth manager with database-backed sessions and requires no attacker interaction with the password change endpoint. The vulnerability is fixed in version 3.9.0 and later.

References

Community reviews

Loading reviews…