Skip to main content
VulnerabilityPublished

CVE-2026-82617: Apache OpenNLP · ReDoS

Affects Apache OpenNLPSource CVE Database V5

0

Not known to be exploited · CVSS 10.0 Critical : upgrade to 3.0.0-M6 as a priority.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 4.0 base score
10.0Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.7% chance of exploitation in 30 days – higher than 55% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.0.0-M6, 2.5.12
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 11 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Apache to 3.0.0-M6 (OpenNLP, Software Foundation/org.apache.opennlp:opennlp-core) or 2.5.12 (OpenNLP, Software Foundation/org.apache.opennlp:opennlp-tools).

Affected software

ProductAffectedFixed in
Apache Software FoundationApache OpenNLPAffected
  • >=3.0.0-M1 <3.0.0-M6
Fixed in
  • 3.0.0-M6
Apache Software FoundationApache OpenNLPAffected
  • >=2.0.0 <2.5.12
Fixed in
  • 2.5.12
MavenApache Software Foundation/org.apache.opennlp:opennlp-corepkg:maven/Apache Software Foundation/org.apache.opennlp:opennlp-coreOther threatsAffected
  • >=3.0.0-M1 <3.0.0-M6
Fixed in
  • 3.0.0-M6
MavenApache Software Foundation/org.apache.opennlp:opennlp-toolspkg:maven/Apache Software Foundation/org.apache.opennlp:opennlp-toolsOther threatsAffected
  • >=2.0.0 <2.5.12
Fixed in
  • 2.5.12

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade Apache OpenNLP to version 2.5.12 or later, or to 3.0.0-M6 or later if using the 3.0.0 milestone line. These versions contain fixes that eliminate the ambiguous nested quantifiers causing the vulnerability. No other mitigation is required once upgraded.

Description

CVE-2026-82617 is a critical vulnerability in Apache OpenNLP affecting versions from 2.0.0 through 2.5.11 and 3.0.0-M1 through 3.0.0-M5. It involves two built-in name-finder regex patterns for EMAIL and URL that contain ambiguous nested quantifiers. These patterns can cause super-linear backtracking or unbounded recursion when processing crafted inputs, leading to high CPU usage or thread crashes. The vulnerability allows denial of service without requiring authentication or special configuration. Fixed versions 2.5.12 and 3.0.0-M6 address this issue.

References

Community reviews

Loading reviews…