CVE-2026-82845: Masteriyo LMS (WordPress plugin) · Deserialization of Untrusted Data
Affects Masteriyo LMS (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 9.9 Critical : upgrade to 3.4.1 as a priority.
Data as of 28 Oct 2026, 05:12 UTC
- EPSS
- 0.6% chance of exploitation in 30 days – higher than 50% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.4.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 12 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade Masteriyo LMS (WordPress plugin) to 3.4.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Masteriyo LMS | Affected
| Fixed in
|
AI-suggested
Upgrade the Masteriyo LMS WordPress plugin to version 3.4.1 or later, where this vulnerability is fixed. No other mitigation details are provided. Patch status is confirmed by the version boundary in the affectedVersions field.
Description
The Masteriyo LMS WordPress plugin before 3.4.1 does not prevent user-supplied values held as metadata from being deserialized when they are read back, allowing users with a minimal account to inject arbitrary PHP objects and, by way of a class shipped in a library bundled with the Masteriyo LMS WordPress plugin before 3.4.1, write and execute arbitrary code on the server. A weaker form of the same issue is reachable without an account and yields an arbitrary file write rather than code execution.