CVE-2026-83559: Apache Wicket · Improper Encoding or Escaping of Output
Affects Apache WicketSource CVE Database V5
Not known to be exploited · CVSS 7.4 High · fixed in 8.20.0 : patch Apache Wicket soon.
Data as of 1 Nov 2026, 22:43 UTC
Thin evidence
One scorer or none| CNA (apache) | CVSS 4.0 | 7.4 |
|---|
- Patch
- Available – fixed in 8.20.0
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:H/VI:H/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 1 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Wicketorg.apache.wicket:wicket-core | Affected
| Fixed in– |
Mavenorg.apache.wicket/wicket-corepkg:maven/org.apache.wicket/wicket-coreOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade Apache Wicket to versions 8.20.0, 9.25.0, or 10.12.0 or later, where this vulnerability is fixed. No other mitigation or workaround is specified. Applications using the vulnerable method should ensure they do not embed untrusted data in JavaScript string literals without proper escaping, but the primary recommendation is to apply the official fix.
Description
CVE-2026-83559 is a vulnerability in Apache Wicket affecting versions 8.0.0 through 8.19.0, 9.0.0 through 9.24.0, and 10.0.0 through 10.11.0. It involves improper encoding or escaping of output in the JavaScriptUtils#escapeQuotes() method, which fails to escape backslashes properly. This flaw can allow injected JavaScript code to execute in the context of the user's session if attacker-controlled data is passed through this method and embedded in JavaScript string literals. The issue is fixed in versions 8.20.0, 9.25.0, and 10.12.0.