Skip to main content
VulnerabilityPublished

CVE-2026-84172: Apache Wicket · Exposed Files or Directories

Affects Apache WicketSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.3 Medium · fixed in 8.20.0 : update Apache Wicket when convenient.

Data as of 1 Nov 2026, 22:46 UTC

CVSS 4.0 base score
6.3Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (apache)CVSS 4.06.3
Patch
Available – fixed in 8.20.0
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 1 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
Apache Wicketorg.apache.wicket:wicket-coreAffected
  • >=8.0.0 <=8.19.0
  • >=9.0.0 <=9.24.0
  • >=10.0.0 <=10.11.0
Fixed in–
Mavenorg.apache.wicket/wicket-corepkg:maven/org.apache.wicket/wicket-coreOther threatsAffected
  • >=8.0.0 <=8.19.0
  • >=9.0.0 <=9.24.0
  • >=10.0.0 <=10.11.0
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade Apache Wicket to versions 8.20.0, 9.25.0, or 10.12.0 where this issue is fixed. Deployments should avoid placing wicket-core in a class loader isolated from the application's component classes, such as shared library directories or global modules. Standard packaging with wicket-core inside the web archive is not affected and requires no additional action.

Description

Apache Wicket versions 8.0.0 through 8.19.0, 9.0.0 through 9.24.0, and 10.0.0 through 10.11.0 have a vulnerability where developer-authored component markup templates can be read by external parties under certain deployment configurations. This occurs when wicket-core is loaded by a class loader that cannot see the application's component classes, causing the system to incorrectly serve component markup templates as static HTML files. The exposure is read-only and limited to template content, without access to user data or credentials. Typical deployments with wicket-core in the web archive are not affected. The issue is fixed in Apache Wicket versions 8.20.0, 9.25.0, and 10.12.0.

References

Community reviews

Loading reviews…