Skip to main content
VulnerabilityPublished

CVE-2026-86247: Apache Tomcat Native · Race Condition Within a Thread

Affects Apache Tomcat NativeSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.4 High · fixed in 1.3.9 : patch Apache Tomcat Native soon.

Data as of 6 Nov 2026, 23:24 UTC

CVSS 3.1 base score
7.4High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 10% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.3.9
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 23 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
Apache Software FoundationApache Tomcat NativeAffected
  • >=2.0.0 <=2.0.15
  • >=1.3.0 <=1.3.8
Fixed in–

AI-suggested

Users should upgrade affected Apache Tomcat Native versions to 1.3.9 or 2.0.16 or later, where this race condition vulnerability is fixed. No other mitigations are indicated by the vendor advisory.

Description

A race condition vulnerability in Apache Tomcat Native allows client certificate verification requirements to be downgraded under certain configurations. This affects versions 1.3.0 through 1.3.8 and 2.0.0 through 2.0.15. The issue is fixed in versions 1.3.9 and 2.0.16. The vulnerability has a high severity rating with a CVSS score of 7.4.

References

Community reviews

Loading reviews…