Skip to main content
VulnerabilityPublished

CVE-2026-86243: Apache Tomcat Native · Buffer Over-read

Affects Apache Tomcat NativeSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.5 High.

Data as of 5 Nov 2026, 00:01 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 46% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 23 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
Apache Software FoundationApache Tomcat NativeAffected
  • >=2.0.0 <=2.0.15
  • >=1.3.0 <=1.3.8
Fixed in–

AI-suggested

Users should upgrade Apache Tomcat Native to version 1.3.9 or 2.0.16 or later to remediate this vulnerability. No other mitigations are indicated by the vendor advisory. Patch status is confirmed as fixed in these versions.

Description

A buffer over-read vulnerability (CWE-126) exists in Apache Tomcat Native during the TLS handshake process. This flaw allows a malicious user to cause a denial of service (DoS) by triggering a JVM crash. The issue affects Apache Tomcat Native versions from 2.0.0 through 2.0.15 and from 1.3.0 through 1.3.8. Upgrading to versions 1.3.9 or 2.0.16 resolves the vulnerability.

References

Community reviews

Loading reviews…