CVE-2026-86466: Apache Airflow FAB provider · Origin Validation Error
Affects Apache Airflow FAB providerSource CVE Database V5
Mentioned vulnerabilities
Not known to be exploited · CVSS 8.1 High : upgrade to 3.9.0 soon.
Data as of 31 Oct 2026, 08:20 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 30% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.9.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 16 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade Apache Airflow FAB provider and apache-airflow-providers-fab to 3.9.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software FoundationApache Airflow FAB provider | Affected
| Fixed in
|
PyPIapache-airflow-providers-fabpkg:pypi/apache-airflow-providers-fabOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade apache-airflow-providers-fab to version 3.9.0 or later, which includes the fix for this vulnerability. Deployments that have already applied the fix for CVE-2026-75156 (Azure AD path) must also upgrade to address this Authentik OAuth path issue. Since this is a cloud-hosted service component, the vendor manages remediation through updates; administrators should ensure timely application of the official fix.
Description
CVE-2026-86466 is a high-severity vulnerability in the Apache Airflow FAB provider affecting versions prior to 3.9.0. The issue arises because the Authentik OAuth path in the FAB auth manager does not validate the issuer or audience claims of the id_token it accepts. This allows an attacker with a valid token for another application from the same Authentik identity provider to authenticate as any user in Airflow without proper authorization. The vulnerability is fixed in version 3.9.0.