Skip to main content
VulnerabilityPublished

CVE-2026-87040: zephyrproject zephyr · Bounds

Affects zephyrproject zephyrSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.3 High : upgrade to 4.5.0 or 4.3.2 soon.

Data as of 4 Nov 2026, 06:28 UTC

CVSS 3.1 base score
8.3High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (zephyr)CVSS 3.18.3
Patch
Available – fixed in 4.5.0, 4.3.2
CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade zephyrproject zephyr to 4.5.0 or 4.3.2.

Affected software

ProductAffectedFixed in
zephyrprojectzephyrAffected
  • >=4.4.0 <4.5.0
Fixed in
  • 4.5.0
zephyrprojectzephyrAffected
  • >=1.6.0 <4.3.2
Fixed in
  • 4.3.2
GitHubzephyrpkg:github/zephyrOther threatsAffected
  • >=1.6.0 <4.3.2
  • >=4.4.0 <4.5.0
Fixed in
  • 4.3.2
  • 4.5.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in Zephyr versions 4.3.2 and 4.5.0 that rejects any received PDU whose length exceeds the configured maximum receive length. Users should upgrade to these fixed versions to remediate the vulnerability. No additional mitigations are indicated by the vendor advisory.

Description

CVE-2026-87040 is a high-severity vulnerability in the Zephyr open-source Bluetooth LE Controller affecting versions >=1.6.0 <4.3.2 and >=4.4.0 <4.5.0. It arises from improper validation of the on-air LENGTH field of received PDUs against the maximum receive length programmed in the radio. This flaw allows an attacker within radio range to send crafted PDUs with length fields exceeding the configured maximum, leading to out-of-bounds memory reads and writes, remote memory corruption, controller crashes, and potential disclosure of controller memory to the host. The vulnerability affects unencrypted LE connections and certain ISO and extended-advertising PDUs. The issue is fixed in Zephyr versions 4.3.2 and 4.5.0.

References

Community reviews

Loading reviews…