CVE-2026-8814: exifreader · Data Amplification
Affects exifreaderSource CVE Database V5
Public exploit available · CVSS 6.9 Medium : upgrade to 4.39.0 as a priority.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 40% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.39.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:PExploitation evidence
Disclosed: evidence found.
CVE published 19 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: evidence found.
CVSS exploit maturity: proof of concept public
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade exifreader to 4.39.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| exifreader | Affected
| Fixed in
|
npmexifreaderpkg:npm/exifreaderOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
If you cannot patch yet, users should consider disabling asynchronous parsing of PNG files or validating and sanitizing input files to prevent processing of maliciously crafted PNG zTXt chunks.
Description
CVE-2026-8814 affects versions of the exifreader package prior to 4.39.0. The vulnerability arises from improper handling of highly compressed PNG zTXt metadata, where the decompression process does not enforce a maximum decompressed output size. This can lead to data amplification, causing the library to consume excessive memory when parsing crafted PNG files asynchronously. The issue is classified under CWE-409 and has a CVSS 4.0 base score of 6.9, indicating medium severity. No known exploits are reported in the wild, and the vulnerability does not affect cloud services specifically.