CVE-2026-88824: Master Blocks (WordPress plugin) · Cross-Site Scripting (XSS)
Affects Master Blocks (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 8.8 High : upgrade to 1.5.0 soon.
Data as of 3 Nov 2026, 10:58 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 43% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.5.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 19 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.
What to do
Upgrade Master Blocks (WordPress plugin) to 1.5.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Master Blocks | Affected
| Fixed in
|
AI-suggested
Upgrade the Master Blocks plugin to version 1.5.0 or later, where this vulnerability is fixed. Since the vulnerability is due to missing authorization on a REST route and improper output escaping, applying the official update will remediate the issue. No other mitigation is indicated by the vendor advisory.
Description
The Master Blocks WordPress plugin before 1.5.0 does not have authorisation on one of its REST routes, allowing unauthenticated users to update its settings, including a value that is output unescaped in the admin area, leading to Stored XSS that executes in the session of any administrator visiting a wp-admin page.