CVE-2026-90439: F5 NGINX Plus · Heap-based Buffer Overflow
Affects F5 NGINX PlusSource CVE Database V5
Not known to be exploited · CVSS 6.5 Medium : upgrade to 37.1.1.2 or 37.0.6.2 when convenient.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 17% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 37.1.1.2, 37.0.6.2, 1.31.6 +1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:LExploitation evidence
Disclosed: evidence found.
CVE published 15 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade NGINX to 37.1.1.2 or 37.0.6.2 (Plus); 1.31.6 or 1.30.5 (Open Source).
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| F5NGINX Plus | Affected
| Fixed in
|
| F5NGINX Plus | Affected
| Fixed in
|
| F5NGINX Open Source | Affected
| Fixed in
|
| F5NGINX Open Source | Affected
| Fixed in
|
Description
CVE-2026-90439 is a heap-based buffer overflow vulnerability in the ngx_http_v3_module of NGINX Plus and NGINX Open Source when using HTTP/3 with OpenSSL versions up to 3.5.0 under certain configurations. This flaw can cause the NGINX worker process to restart or experience limited data corruption. The issue affects the data plane only and does not expose the control plane. The vulnerability has a medium severity rating with a CVSS score of 6.5.