CVE-2026-91104: HP Linux Imaging and Printing Software (HPLIP) · Heap-based Buffer Overflow
Affects HP Linux Imaging and Printing Software (HPLIP)Source CVE Database V5
Not known to be exploited · CVSS 9.3 Critical · fixed in 3.26.6 : patch HP Linux Imaging and Printing Software (HPLIP) as a priority.
Data as of 31 Oct 2026, 08:20 UTC
- EPSS
- 1.0% chance of exploitation in 30 days – higher than 64% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.26.6
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 16 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| HP Inc.HP Linux Imaging and Printing Software (HPLIP) | Affected
| Fixed in– |
AI-suggested
HP has remediated this vulnerability in version 3.26.6 of HPLIP. Users should upgrade to version 3.26.6 or later to mitigate this issue. No additional vendor advisory content was provided, but the presence of a fixed version indicates an official fix is available.
Description
CVE-2026-91104 is a critical heap-based buffer overflow vulnerability in HP Linux Imaging and Printing Software (HPLIP). It affects versions from 0 up to but not including 3.26.6. The flaw could allow remote attackers to execute code, escalate privileges, cause denial of service, disclose information, or modify files without authorization under certain conditions. HP has identified and remediated this vulnerability.