Skip to main content
VulnerabilityPublished

CVE-2026-91106: HP Linux Imaging and Printing Software (HPLIP) · Heap-based Buffer Overflow

Affects HP Linux Imaging and Printing Software (HPLIP)Source CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.3 Critical : upgrade to 3.26.6 as a priority.

Data as of 31 Oct 2026, 08:20 UTC

CVSS 4.0 base score
9.3Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.0% chance of exploitation in 30 days – higher than 63% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.26.6
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade the Ubuntu ubuntu/hplip package to 3.26.6.

Affected software

ProductAffectedFixed in
HP Inc.HP Linux Imaging and Printing Software (HPLIP)Affected
  • <3.26.6
Fixed in–
Ubuntuubuntu/hplippkg:deb/ubuntu/hplipOther threatsAffected
  • <3.26.6
Fixed in
  • 3.26.6

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

HP has remediated this vulnerability in HPLIP. Users should upgrade to version 3.26.6 or later to apply the official fix. No additional mitigation steps are indicated beyond applying the vendor's patch.

Description

CVE-2026-91106 is a critical heap-based buffer overflow vulnerability in HP Linux Imaging and Printing Software (HPLIP). It affects versions from 0 up to but not including 3.26.6. The vulnerability could allow remote code execution, privilege escalation, denial of service, information disclosure, or unauthorized file modification under certain conditions. HP has identified and remediated multiple vulnerabilities in HPLIP, including this one.

References

Community reviews

Loading reviews…