CVE-2026-92587: n8n · Untrusted Search Path
Affects n8nSource CVE Database V5
Not known to be exploited · CVSS 5.3 Medium : upgrade to 1.123.76 when convenient.
Data as of 31 Oct 2026, 20:34 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 5.3 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 5.0 |
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 23% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.123.76, 2.38.2, 2.37.7
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:L/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 16 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| n8n-ion8n | Affected
| Fixed in
|
| n8n-ion8n | Affected
| Fixed in
|
| n8n-ion8n | Affected
| Fixed in
|
GitHubn8n-io/n8npkg:github/n8n-io/n8nOther threats | Affected
| Fixed in
|
npmn8npkg:npm/n8nOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade n8n to version 1.123.76, 2.37.7, or 2.38.2 where the vulnerability is fixed. As a workaround, disable the Git node by adding 'n8n-nodes-base.git' to the NODES_EXCLUDE configuration setting. No other actions are indicated by the vendor advisory.
Description
CVE-2026-92587 is a medium severity vulnerability in the n8n workflow automation platform affecting certain versions before 1.123.76, 2.37.7, and 2.38.2. The Git node improperly validated relative remote URLs, allowing an authenticated user to bypass sandbox restrictions and access git repositories outside the intended directory. This could lead to unauthorized reading of repository contents. The issue is fixed in versions 1.123.76, 2.37.7, and 2.38.2. A workaround is to disable the Git node by excluding it via configuration.