Skip to main content
VulnerabilityPublished

CVE-2026-93766: Happyforms Pro (WordPress plugin) · Cross-site Scripting

Affects Happyforms Pro (WordPress plugin)Source CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.2 High.

Data as of 7 Nov 2026, 11:49 UTC

CVSS 3.1 base score
7.2High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (Wordfence)CVSS 3.17.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 7 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
HappyformsHappyforms ProAffected
  • <=1.38.9
Fixed in–

AI-suggested

Since the affected versions are up to and including 1.38.9, users should upgrade to a version later than 1.38.9 once available. Until then, consider applying input validation or output escaping workarounds if feasible. Monitor the vendor's advisory for official fixes and updates. No cloud service remediation applies as this is a WordPress plugin.

Description

Happyforms Pro plugin for WordPress versions up to and including 1.38.9 is vulnerable to a stored cross-site scripting (XSS) flaw via the 'happyforms_client_referer' parameter. This vulnerability allows unauthenticated attackers to inject malicious scripts that execute when users access the affected pages.

References

Community reviews

Loading reviews…