CVE-2026-94384: amazon-connect-salesforce-lambda · Missing Authorization
Affects amazon-connect-salesforce-lambdaSource CVE Database V5
Not known to be exploited · CVSS 8.1 High · patch available : patch amazon-connect-salesforce-lambda soon.
Data as of 26 Oct 2026, 10:12 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 24% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- CISA SSVC
- Exploitation
- No evidence of active exploitation and no public proof of concept
- Automatable
- Attackers cannot reliably automate steps 1–4 of the kill chain
- Technical impact
- Total control over the software or total information disclosure
CISA SSVC assessment, 2026-09-22.
- Patch
- Available
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 22 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 24 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Amazonamazon-connect-salesforce-lambda | Affected
| Fixed in– |
GitHubamazon-connect/amazon-connect-salesforce-lambdapkg:github/amazon-connect/amazon-connect-salesforce-lambdaOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in amazon-connect-salesforce-lambda version 5.26 and later. Users should upgrade to version 5.26 or above. After upgrading, delete or disable the sfExecuteAWSService Lambda function. If retaining the function is necessary, restrict its invocation strictly to the intended IAM user to prevent unauthorized privilege escalation.
Description
CVE-2026-94384 is a high-severity vulnerability in Amazon's amazon-connect-salesforce-lambda versions 5.15 through 5.24.16. It involves missing authorization checks in a Lambda function (sfExecuteAWSService) that allows any IAM principal with lambda:InvokeFunction permission on the affected function to escalate privileges. This escalation enables performing AWS API operations that the caller's IAM identity is explicitly denied. The issue is resolved in version 5.26 and later by removing or restricting the vulnerable function.