Skip to main content
VulnerabilityPublished Updated

CVE-2026-94588: Proxmox pmg-api · Argument Injection

Affects Proxmox pmg-apiSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 4.4 Medium : upgrade to 9.0.3 when convenient.

Data as of 5 Nov 2026, 00:01 UTC

CVSS 3.1 base score
4.4Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 16% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.0.3
CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade Proxmox pmg-api to 9.0.3.

Affected software

ProductAffectedFixed in
Proxmoxpmg-apiAffected
  • >=9.0.0 <9.0.3
Fixed in
  • 9.0.3

AI-suggested

If you cannot patch yet, restrict access to the pmg-api service to trusted users and consider mitigating CSRF risks by enforcing anti-CSRF tokens or similar protections.

Description

In Proxmox pmg-api, an argument injection vulnerability exists in the package changelog retrieval functionality. This is caused by improper handling of user-supplied input passed to the underlying apt-get command when fetching package changelogs. It requires authentication but can be exploited in a CSRF-style attack.

References

Community reviews

Loading reviews…