Skip to main content
VulnerabilityPublished

CVE-2026-94603: podman · Protection Mechanism Failure

Affects podmanSource CVE Database V5

0

Not known to be exploited · CVSS 10.0 Critical : upgrade to 6.1.3 or 5.8.8 as a priority.

Data as of 27 Oct 2026, 05:11 UTC

CVSS 3.1 base score
10.0Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 44% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CISA SSVC
Exploitation
No evidence of active exploitation and no public proof of concept
Automatable
Attackers can reliably automate steps 1–4 of the kill chain
Technical impact
Total control over the software or total information disclosure

CISA SSVC assessment, 2026-10-13.

Patch
Available – fixed in 6.1.3, 5.8.8
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade podman and podman-container-tools/podman to 6.1.3 or 5.8.8.

Affected software

ProductAffectedFixed in
podman-container-toolspodmanAffected
  • >=6.0.0 <6.1.3
Fixed in
  • 6.1.3
podman-container-toolspodmanAffected
  • >=4.4.0 <5.8.8
Fixed in
  • 5.8.8
GitHubpodman-container-tools/podmanpkg:github/podman-container-tools/podmanOther threatsAffected
  • >=4.4.0 <5.8.8
  • >=6.0.0 <6.1.3
Fixed in
  • 5.8.8
  • 6.1.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Podman to version 5.8.8 or later in the 5.x series, or to version 6.1.3 or later in the 6.x series, where this vulnerability is fixed. Rootless containers are not affected by this issue.

Description

Podman versions from 4.4.0 up to but not including 5.8.8, and from 6.0.0 up to but not including 6.1.3, contain a vulnerability where the 'podman run' command treats images with the io.podman.annotations.checkpoint.runtime.name annotation as checkpoints. This causes the tool to ignore user-supplied container creation restrictions such as --cap-drop=ALL, potentially allowing weaker sandbox settings and capabilities. Rootless containers are not affected. The issue is fixed in versions 5.8.8 and 6.1.3.

References

Community reviews

Loading reviews…