Skip to main content
VulnerabilityPublished

vm2 has access to `VM2_INTERNAL_STATE_DO_NOT_USE_OR_PROGRAM_WILL_FAIL`

Affects vm2Source GCVE Database

0

CVSS 5.3 Medium : upgrade to 3.11.2 when convenient.

Data as of 27 Oct 2026, 00:07 UTC

CVSS 3.1 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 3.11.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

What to do

Upgrade vm2 to 3.11.2.

Affected software

ProductAffectedFixed in
npmvm2Affected
  • <3.11.2
Fixed in
  • 3.11.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

### Summary https://github.com/patriksimek/vm2/security/advisories/GHSA-wp5r-2gw5-m7q7 is not fully patched. ### Details It is still possible to get access to `VM2_INTERNAL_STATE_DO_NOT_USE_OR_PROGRAM_WILL_FAIL`. ### PoC ```js const {VM} = require("vm2"); const vm = new VM(); console.log(vm.run(` globalThis['VM2_INTERNAL_STATE_DO_NOT_USE_OR_PROGRAM_WILL_FAIL'] `)); ```

References

Community reviews

Loading reviews…