CVE-2026-44003: vm2's Transformer Fast-Path Bypass Exposes Internal State Variable
Affects vm2Source GCVE Database
Not known to be exploited · CVSS 5.3 Medium : upgrade to 3.11.0 when convenient.
Data as of 5 Nov 2026, 23:24 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 16% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.11.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 13 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Upgrade vm2 to 3.11.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| npmvm2 | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in vm2 version 3.11.0 that addresses this issue by extending the fast-path check to include the with keyword and the internal state variable name, preventing the AST transformation bypass. Users should upgrade to vm2 version 3.11.0 or later to remediate this vulnerability. No additional mitigation steps are required beyond applying the official fix.
Description
vm2's code transformer optimization bypasses AST analysis for code lacking the keywords catch, import, or async, allowing sandboxed code to access an internal state variable exposing security functions. This bypass disables internal checks that normally prevent access to VM2_INTERNAL_STATE_DO_NOT_USE_OR_PROGRAM_WILL_FAIL, exposing methods like handleException, wrapWith, and import. While these methods are currently defensive and not direct escape vectors, the bypass represents a complete security control failure and could enable future exploits if sensitive methods are added. The vulnerability affects all vm2 versions prior to 3.11.0 and requires no special configuration. A patch is available in version 3.11.0 that adds additional keyword checks to prevent this bypass.
References
- github.com/patriksimek/vm2/security/advisories/GHSA-wp5r-2gw5-m7q7 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-44003 (opens in a new tab)
- github.com/patriksimek/vm2/commit/9f0484862b74be3584169db282236a47f418ddbb (opens in a new tab)
- github.com/patriksimek/vm2 (opens in a new tab)
- github.com/patriksimek/vm2/releases/tag/v3.11.0 (opens in a new tab)