Skip to main content
VulnerabilityPublished

CVE-2026-24781: VM2 Has Sandbox Breakout Through Inspect Function

Affects vm2Source GCVE Database

0
Authoritative record:CVE-2026-24781· Critical 9.8

Not known to be exploited · CVSS 9.8 Critical : upgrade to 3.11.0 as a priority.

Data as of 27 Oct 2026, 01:43 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 3.11.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade vm2 to 3.11.0.

Affected software

ProductAffectedFixed in
npmvm2Affected
  • <3.11.0
Fixed in
  • 3.11.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and the vulnerability is fixed in VM2 version 3.11.0. Users should upgrade to version 3.11.0 or later to remediate this issue. No other mitigations are specified or required according to the vendor advisory.

Description

VM2 versions prior to 3.11.0 contain a sandbox breakout vulnerability via the inspect function. This flaw allows attackers to escape the VM2 sandbox and execute arbitrary commands on the host system. The vulnerability arises from the way the inspect method unwraps proxies, enabling access to internal proxy handlers and ultimately the host environment. A proof-of-concept demonstrates how an attacker can leverage this to run arbitrary code. The vulnerability is rated critical with a CVSS score of 9.8 and has been fixed in version 3.11.0.

References

Community reviews

Loading reviews…