Skip to main content
VulnerabilityPublished

CVE-2026-9557: mautic · Server-Side Request Forgery (SSRF)

Affects mauticSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.4 Medium · fixed in 7.1.2 : update mautic when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
6.4Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 3% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 7.1.2, 6.0.9, 5.2.11 +1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade mautic/core to 7.1.2, 6.0.9, 5.2.11 or 4.4.20.

Affected software

ProductAffectedFixed in
GitHubmautic/mauticpkg:github/mautic/mauticOther threatsAffected
  • 4.0.0 – 7.0.0
4 affected builds
Fixed in–
Packagistmautic/corepkg:composer/mautic/coreOther threatsAffected
  • >=4.0.0 <4.4.20
  • >=5.0.0 <5.2.11
  • >=6.0.0 <6.0.9
  • >=7.0.0 <7.1.2
Fixed in
  • 4.4.20
  • 5.2.11
  • 6.0.9
  • 7.1.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, restrict authenticated user privileges to trusted users only and monitor for unusual outbound requests from the server. Avoid exposing sensitive internal services that could be targeted via SSRF.

Description

CVE-2026-9557 is a Server-Side Request Forgery (SSRF) vulnerability in Mautic's Focus component. It allows an authenticated user to cause the hosting server to make HTTP requests to arbitrary internal or external destinations due to insufficient validation of user-supplied URLs. This can enable internal network reconnaissance or interaction with unintended network resources. The vulnerability affects specific versions 4.0.0, 5.0.0, 6.0.0, and 7.0.0 of Mautic. The CVSS score is 6.4, indicating a medium severity level.

References

Community reviews

Loading reviews…