Skip to main content
VulnerabilityPublished

CVE-2026-9558: mautic · Template Injection

Affects mauticSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.9 Critical · fixed in 7.1.2 : patch mautic as a priority.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 3.1 base score
9.9Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 47% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 7.1.2, 6.0.9, 5.2.11 +1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    Public exploit code: GitHub proofs of concept

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade mautic/core to 7.1.2, 6.0.9, 5.2.11 or 4.4.20.

Affected software

ProductAffectedFixed in
GitHubmautic/mauticpkg:github/mautic/mauticOther threatsAffected
  • 1.3.0 – 7.0.0
4 affected builds
Fixed in–
Packagistmautic/corepkg:composer/mautic/coreOther threatsAffected
  • >=1.3.0 <4.4.20
  • >=5.0.0 <5.2.11
  • >=6.0.0 <6.0.9
  • >=7.0.0 <7.1.2
Fixed in
  • 4.4.20
  • 5.2.11
  • 6.0.9
  • 7.1.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, restrict theme creation and upload permissions to fully trusted users only.

Description

CVE-2026-9558 is a critical Server-Side Template Injection (SSTI) vulnerability in Mautic's theme engine. It allows authenticated users with theme creation or upload permissions to execute arbitrary code on the hosting server or access restricted system files. The vulnerability arises because the platform renders uploaded Twig templates without sandboxing or strict function restrictions. This can lead to remote code execution and full compromise of confidentiality, integrity, and availability of the affected system.

References

Community reviews

Loading reviews…