CVE-2026-9617: DALIBO PostgreSQL Anonymizer · SQL Injection
Affects DALIBO PostgreSQL AnonymizerSource CVE Database V5
Not known to be exploited · CVSS 6.8 Medium : upgrade to 3.1.0 when convenient.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 16% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.1.0
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 27 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade PostgreSQL Anonymizer and dalibo/postgresql_anonymizer to 3.1.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| DALIBOPostgreSQL Anonymizer | Affected
| Fixed in
|
GitHubdalibo/postgresql_anonymizerpkg:github/dalibo/postgresql_anonymizerOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade to PostgreSQL Anonymizer version 3.1.0 or later, where this vulnerability is fixed. For PostgreSQL 15 and later, the default revocation of CREATE TABLE permission on the public schema reduces risk, but users should ensure that only trusted users have CREATE TABLE privileges. Patch status is not explicitly stated beyond the fixed version; therefore, verify with the vendor advisory for the latest remediation guidance.
Description
CVE-2026-9617 is a SQL injection vulnerability in the DALIBO PostgreSQL Anonymizer that allows a user to escalate privileges to superuser by injecting malicious code into a column identifier when creating a table. Execution of this code occurs if a superuser calls the k-anonymity function. The risk is higher on PostgreSQL 14 or instances upgraded from that version, while PostgreSQL 15 and later reduce risk by revoking public schema creation permissions by default. The vulnerability is fixed in PostgreSQL Anonymizer version 3.1.0 and later.