Skip to main content
CVE-2026-27651VulnerabilityPublished Updated

SUSE · security update for nginx

Affects SUSESource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2026-27651· High 7.5

Not known to be exploited · CVSS 7.5 High · fixed in Red Hat package updates : patch the Red Hat redhat/nginx package soon.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.9% chance of exploitation in 30 days – higher than 61% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.29.7, 1.28.3, R36 P3 +3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 24 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade NGINX Open Source to 1.29.7 or 1.28.3; NGINX Plus to R36 P3, R35 P2 or R32 P5; the Red Hat redhat/nginx package to 1.29.0.

Affected software

ProductAffectedFixed in
F5NGINX Open SourceAffected
  • >=1.29.0 <1.29.7
Fixed in
  • 1.29.7
F5NGINX Open SourceAffected
  • >=0.5.15 <1.28.3
Fixed in
  • 1.28.3
F5NGINX PlusAffected
  • >=R34
  • >=R33
  • =R36
  • =R35
  • =R32
Fixed in
  • R36 P3
  • R35 P2
  • R32 P5
Red Hatredhat/nginxpkg:rpm/redhat/nginxOther threatsAffected
  • <1.29.0
Fixed in
  • 1.29.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released security updates that fix this vulnerability. Users of affected NGINX versions should apply the official patches provided by Red Hat as detailed in their advisories (e.g., RHSA-2026:13634). Since this is not a cloud service, remediation requires updating the affected software versions. Patch status is confirmed by the vendor advisory. No alternative mitigations or workarounds are specified.

Description

This update for nginx fixes the following issues - CVE-2026-27651: denial of service via undisclosed requests when the `ngx_mail_auth_http_module` is enabled (bsc#1260415). - CVE-2026-32647: NGINX worker memory over-read or over-write via a specially crafted MP4 file (bsc#1260420). - CVE-2026-40701: heap use-after-free in the worker process when the `ssl_verify_client` and the `ssl_ocsp` directives are set due to issue in the `ngx_http_ssl_module` module (bsc#1265229). - CVE-2026-42934: heap buffer overread in the worker process due to issue in the `ngx_http_charset_module` module (bsc#1265231). - CVE-2026-42945: heap buffer overflow via crafted HTTP requests due to issue in `ngx_http_rewrite_module` (bsc#1265232). - CVE-2026-42946: excessive memory allocation and data overread due to issue in the `ngx_http_scgi_module` and `ngx_http_uwsgi_module` modules (bsc#1265233).

References

Community reviews

Loading reviews…