Skip to main content
VulnerabilityPublished Updated

CVE-2026-44285: Server-Side Request Forgery (SSRF) in labring FastGPT

Affects labring FastGPTSource GCVE Database

0
Compare

Not known to be exploited · CVSS 7.7 High · fixed in 4.15.0 : patch labring FastGPT soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
7.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 18% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.15.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
GitHublabring/FastGPTpkg:github/labring/FastGPTOther threatsAffected
  • =4.15.0-beta1
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

The vulnerability is fixed in FastGPT version 4.15.0-beta1. Users should upgrade to this version or later to remediate the issue. Since this is not a cloud service, remediation depends on applying the vendor's fixed version. Patch status is not explicitly stated beyond the fix in 4.15.0-beta1, so users should verify the upgrade and consult the vendor for any additional guidance.

Description

FastGPT is an AI Agent building platform. Prior to 4.15.0-beta1, a Server-Side Request Forgery (SSRF) vulnerability allows an authenticated attacker to bypass the global isInternalAddress network protection and make arbitrary HTTP GET requests to internal network services. This is achieved by exploiting an incomplete fix in the dataset preview endpoint /api/core/dataset/file/getPreviewChunks when utilizing the externalFile data import type. This vulnerability is fixed in 4.15.0-beta1.

References

Community reviews

Loading reviews…