Skip to main content
VulnerabilityPublished Updated

CVE-2026-44286: labring FastGPT · Server-Side Request Forgery (SSRF)

Affects labring FastGPTSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 2.3 Low : upgrade to 4.14.17 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
2.3Low
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 13% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.14.17
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade FastGPT and labring/FastGPT to 4.14.17.

Affected software

ProductAffectedFixed in
labringFastGPTAffected
  • <4.14.17
Fixed in
  • 4.14.17
GitHublabring/FastGPTpkg:github/labring/FastGPTOther threatsAffected
  • <4.14.17
Fixed in
  • 4.14.17

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

This vulnerability is patched in FastGPT version 4.14.17. Users should upgrade to version 4.14.17 or later to remediate the issue. No other official remediation or temporary fixes are documented. Since this is not a cloud service, remediation depends on applying the vendor's patch.

Description

FastGPT is an AI Agent building platform. Prior to version 4.14.17, an unauthenticated Server-Side Request Forgery (SSRF) vulnerability allows attackers (or authenticated users with App editing privileges) to send arbitrary HTTP requests to internal/private network addresses. The fetchData function in the lafModule workflow node uses axios to fetch user-controlled URLs without validating them against the application's internal network blocklist guard (isInternalAddress), bypassing SSRF protections. This issue has been patched in version 4.14.17.

References

Community reviews

Loading reviews…