Skip to main content
VulnerabilityPublished

CVE-2026-45414: Decidim · JWT-backed authentication can be replayed across organizations

Affects decidimSource GCVE Database

0
Compare

Not known to be exploited · CVSS 8.5 High : upgrade to 0.31.5 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
8.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 39% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.31.5, 0.32.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade decidim to 0.31.5; decidim to 0.32.0.

Affected software

ProductAffectedFixed in
RubyGemsdecidimAffected
  • <0.31.5
Fixed in
  • 0.31.5
RubyGemsdecidimAffected
  • >=0.32.0.rc1 <0.32.0
Fixed in
  • 0.32.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in Decidim versions 0.31.5 and later, as indicated by the referenced pull requests (https://github.com/decidim/decidim/pull/16673 and https://github.com/decidim/decidim/pull/16756). Users should upgrade to version 0.31.5 or later to remediate this issue. As a workaround, disabling JWT credentials via the system panel (/system) can prevent exploitation until the patch is applied.

Description

Decidim versions prior to 0.31.5 have a vulnerability where JSON Web Tokens (JWTs) issued for one organization can be replayed against another organization's API. This allows unauthorized access to sensitive participant details and mutation paths intended for that other organization. The issue arises because JWT authentication is not sufficiently bound to the host organization context, enabling cross-organization token reuse.

References

Community reviews

Loading reviews…