DeepSeek Harness prior to 0.1.2-alpha.2, and specifically commit 3e24087, contains a missing authentication
Source GCVE Database
Not known to be exploited · CVSS 8.6 High : upgrade to 0.1.2-alpha.2 soon.
Data as of 4 Nov 2026, 22:53 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 8.6 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 8.4 |
- Patch
- Available – fixed in 0.1.2-alpha.2
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 4 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Upgrade deepseek-harness to 0.1.2-alpha.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| deepseek-aideepseek-harness | Affected
| Fixed in
|
GitHubdeepseek-harnesspkg:github/deepseek-harnessOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
If you cannot patch yet, restrict local access to trusted users only and monitor for suspicious local activity involving DeepSeek Harness. Avoid running the vulnerable versions on multi-user systems or where untrusted local processes exist.
Description
DeepSeek Harness versions prior to 0.1.2-alpha.2, specifically commit 3e24087, have a missing authentication vulnerability in the web profile HTTP and WebSocket RPC control plane. This flaw allows any local process, including those running under different OS users, to access unauthenticated session methods such as session.create and session.prompt. Exploitation enables attackers to execute arbitrary commands as the victim user, intercept live session traffic and logs, and bypass human tool-approval checks.
References
- nvd.nist.gov/vuln/detail/CVE-2026-82033 (opens in a new tab)
- github.com/deepseek-ai/deepseek-harness/commit/3e24087bfaeabe40b58ba2f7b936895b8f93fe27 (opens in a new tab)
- github.com/deepseek-ai/deepseek-harness/releases/tag/dsh-v0.1.2-alpha.2 (opens in a new tab)
- vulncheck.com/advisories/deepseek-harness-unauthenticated-rpc-command-execution (opens in a new tab)