CVE-2025-26699: Django Vulnerable to Allocation of Resources Without Limits or Throttling
Affects DjangoSource GCVE Database
Not known to be exploited · CVSS 5.0 Medium : upgrade to 4.2.20 when convenient.
Data as of 5 Nov 2026, 00:01 UTC
- EPSS
- 0.8% chance of exploitation in 30 days – higher than 57% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.2.20, 5.0.13, 5.1.7
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:N/A:LExploitation evidence
Disclosed: evidence found.
CVE published 6 Mar 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Upgrade Django to 4.2.20; Django to 5.0.13; Django to 5.1.7.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| PyPIDjango | Affected
| Fixed in
|
| PyPIDjango | Affected
| Fixed in
|
| PyPIDjango | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Apply the official patches by upgrading Django to versions 4.2.20, 5.0.13, or 5.1.7 or later. These versions contain fixes that address the resource exhaustion vulnerability. No additional mitigation is required if these versions are in use.
Description
Django versions prior to 4.2.20, 5.0.13, and 5.1.7 contain a vulnerability in the django.utils.text.wrap() method and the wordwrap template filter. This flaw allows a potential denial-of-service (DoS) attack when processing very long strings, leading to resource exhaustion. The issue is fixed in the specified patched versions.
References
- nvd.nist.gov/vuln/detail/CVE-2025-26699 (opens in a new tab)
- github.com/django/django/commit/4f2765232336b8ad0afd8017d9d912ae93470017 (opens in a new tab)
- github.com/django/django/commit/8dbb44d34271637099258391dfc79df33951b841 (opens in a new tab)
- github.com/django/django/commit/e88f7376fe68dbf4ebaf11fad1513ce700b45860 (opens in a new tab)
- docs.djangoproject.com/en/dev/releases/security (opens in a new tab)
- github.com/django/django (opens in a new tab)
- github.com/pypa/advisory-database/tree/main/vulns/django/PYSEC-2025-13.yaml (opens in a new tab)
- groups.google.com/g/django-announce (opens in a new tab)
- lists.debian.org/debian-lts-announce/2025/03/msg00012.html (opens in a new tab)
- djangoproject.com/weblog/2025/mar/06/security-releases (opens in a new tab)
- openwall.com/lists/oss-security/2025/03/06/12 (opens in a new tab)