CVE-2025-12082: Drupal CivicTheme Design System allows Forceful Browsing
Affects drupal/civicthemeSource GCVE Database
Not known to be exploited · CVSS 7.5 High : upgrade to 1.12.0 soon.
Data as of 29 Oct 2026, 23:13 UTC
- Patch
- Available – fixed in 1.12.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 29 Oct 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade drupal/civictheme to 1.12.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Packagistdrupal/civictheme | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade to Drupal CivicTheme Design System version 1.12.0 or later to remediate this vulnerability. A patch is available and should be applied promptly to prevent unauthorized access via forceful browsing.
Description
Drupal CivicTheme Design System versions before 1.12.0 contain an incorrect authorization vulnerability that allows forceful browsing. This flaw could enable unauthorized users to access restricted resources. The issue is fixed in version 1.12.0. The vulnerability has a high severity with a CVSS score of 7.5.