CVE-2025-12083: Drupal CivicTheme Design System allows Cross-Site Scripting (XSS)
Affects drupal/civicthemeSource GCVE Database
Not known to be exploited · CVSS 6.1 Medium : upgrade to 1.12.0 when convenient.
Data as of 29 Oct 2026, 23:13 UTC
- Patch
- Available – fixed in 1.12.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 29 Oct 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade drupal/civictheme to 1.12.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Packagistdrupal/civictheme | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and the issue is fixed in Drupal CivicTheme Design System version 1.12.0. Users should upgrade to version 1.12.0 or later to remediate this vulnerability.
Description
A Cross-Site Scripting (XSS) vulnerability exists in the Drupal CivicTheme Design System prior to version 1.12.0. This flaw allows improper neutralization of input during web page generation, potentially enabling attackers to execute malicious scripts in users' browsers. The issue is fixed in version 1.12.0.