CVE-2025-10926: Drupal JSON Field is vulnerable to XSS
Affects drupal/json_fieldSource GCVE Database
Not known to be exploited · CVSS 6.1 Medium : upgrade to 1.5 when convenient.
Data as of 29 Oct 2026, 23:13 UTC
- Patch
- Available – fixed in 1.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 29 Oct 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade drupal/json_field to 1.5.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Packagistdrupal/json_field | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade the Drupal JSON Field module to version 1.5 or later, where this vulnerability is fixed. Applying this official fix fully mitigates the issue. No additional mitigation steps are required if the module is updated.
Description
A Cross-Site Scripting (XSS) vulnerability exists in the Drupal JSON Field module versions before 1.5. This flaw allows improper neutralization of input during web page generation, potentially enabling attackers to execute malicious scripts in the context of the affected application. The vulnerability has a CVSS score of 6.1, indicating a medium severity level. A fix is available in version 1.5 of the JSON Field module.