CVE-2025-10927: Drupal Plausible tracking is vulnerable to XSS
Affects drupal/plausible_trackingSource GCVE Database
Not known to be exploited · CVSS 6.1 Medium : upgrade to 1.0.2 when convenient.
Data as of 29 Oct 2026, 23:13 UTC
- Patch
- Available – fixed in 1.0.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 29 Oct 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade drupal/plausible_tracking to 1.0.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Packagistdrupal/plausible_tracking | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade the Drupal Plausible tracking module to version 1.0.2 or later to remediate this vulnerability. Applying this official fix eliminates the risk of exploitation. No additional mitigation steps are required once the patch is applied.
Description
Drupal Plausible tracking versions before 1.0.2 contain a Cross-Site Scripting (XSS) vulnerability due to improper neutralization of input during web page generation. This vulnerability allows attackers to inject malicious scripts that can execute in the context of the affected web application. The issue is fixed in version 1.0.2.