CVE-2025-10931: Drupal Umami Analytics allows Cross-Site Scripting (XSS)
Affects drupal/umami_analyticsSource GCVE Database
Not known to be exploited · CVSS 3.8 Low : upgrade to 1.0.1 when convenient.
Data as of 29 Oct 2026, 23:13 UTC
- Patch
- Available – fixed in 1.0.1
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 29 Oct 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade drupal/umami_analytics to 1.0.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Packagistdrupal/umami_analytics | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Drupal Umami Analytics to version 1.0.1 or later, where this vulnerability is fixed. Since a patch is available, applying the official fix is the recommended remediation. No additional mitigation steps are indicated.
Description
Drupal Umami Analytics versions before 1.0.1 contain a Cross-Site Scripting (XSS) vulnerability due to improper input neutralization during web page generation. This flaw allows an attacker with high privileges to inject malicious scripts without user interaction. The vulnerability is fixed in version 1.0.1.