Skip to main content
VulnerabilityPublished Updated

jsii-diff · Duplicate Advisory: Command Injection

Affects jsii-diffSource GCVE Database

0

CVSS 7.8 High : upgrade to 1.131.0 soon.

Data as of 8 Aug 2026, 15:36 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1.131.0
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

What to do

Upgrade jsii-diff to 1.131.0.

Affected software

ProductAffectedFixed in
npmjsii-diffAffected
  • <1.131.0
Fixed in
  • 1.131.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade to jsii-diff version 1.131.0 or later to remediate this vulnerability. A patch is available and upgrading is the recommended action.

Description

A command injection vulnerability exists in the npm package loading component of AWS jsii-diff before version 1.131.0. This flaw allows context-dependent attackers to execute arbitrary OS commands by supplying crafted package specifiers to the npm: source argument. The vulnerability is addressed in jsii-diff version 1.131.0 and later.

References

Community reviews

Loading reviews…