Skip to main content
VulnerabilityPublished Updated

Duplicate Advisory: uutils coreutils has an Improper Check for Unusual or Exceptional Conditions

Affects coreutilsSource GCVE Database

0

CVSS 4.4 Medium : upgrade to 0.6.0 when convenient.

Data as of 7 Jul 2026, 12:28 UTC

CVSS 3.1 base score
4.4Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 0.6.0
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N

What to do

Upgrade coreutils to 0.6.0.

Affected software

ProductAffectedFixed in
crates.iocoreutilsAffected
  • <0.6.0
Fixed in
  • 0.6.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, administrators should be aware that printenv may not show all environment variables and consider alternative methods to inspect environment variables containing non-UTF-8 bytes.

Description

### Duplicate Advisory This advisory has been withdrawn because it is a duplicate of GHSA-p7h3-7q52-72w8. This link is maintained to preserve external references. ### Original Description The printenv utility in uutils coreutils fails to display environment variables containing invalid UTF-8 byte sequences. While POSIX permits arbitrary bytes in environment strings, the uutils implementation silently skips these entries rather than printing the raw bytes. This vulnerability allows malicious environment variables (e.g., adversarial LD_PRELOAD values) to evade inspection by administrators or security auditing tools, potentially allowing library injection or other environment-based attacks to go undetected.

References

Community reviews

Loading reviews…