CVE-2024-6345: Duplicity · setuptools vulnerable to Command Injection via package URL
Affects duplicitySource GCVE Database
Not known to be exploited · CVSS 8.8 High : upgrade to 2.2.3 or 0.7.09_1 soon.
Data as of 1 Nov 2026, 02:07 UTC
- Patch
- Available – fixed in 2.2.3, 0.7.09_1
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 15 Jul 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.
What to do
Upgrade duplicity to 2.2.3 or 0.7.09_1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewduplicitypkg:brew/duplicityOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and the issue is fixed in setuptools version 70.0. Users of duplicity should upgrade to versions 0.7.09_1 or later and 2.2.3 or later, which include the fixed setuptools version. Applying these updates will remediate the vulnerability. No additional mitigation steps are indicated by the vendor advisory.
Description
CVE-2024-6345 is a high-severity vulnerability in the package_index module of pypa/setuptools versions up to 69.1.1. It allows remote code execution via command injection through download functions that handle package URLs. This flaw can be exploited if user-controlled inputs are passed to these functions, enabling arbitrary command execution on the affected system. The vulnerability is fixed in setuptools version 70.0. The affected product duplicity includes vulnerable versions prior to 0.7.09_1 and 2.2.3, with patches available.
References
- nvd.nist.gov/vuln/detail/CVE-2024-6345 (opens in a new tab)
- github.com/pypa/setuptools/pull/4332 (opens in a new tab)
- github.com/pypa/setuptools/commit/88807c7062788254f654ea8c03427adc859321f0 (opens in a new tab)
- github.com/pypa/setuptools (opens in a new tab)
- huntr.com/bounties/d6362117-ad57-4e83-951f-b8141c6e7ca5 (opens in a new tab)
- lists.debian.org/debian-lts-announce/2024/09/msg00018.html (opens in a new tab)