Skip to main content
CVE-2026-121936VulnerabilityPublished

easyVoice before 0.0.23 contains a server-side request forgery vulnerability that allows unauthenticated attackers to

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-121936· Medium 6.9

Not known to be exploited · CVSS 6.9 Medium : upgrade to 0.0.23 when convenient.

Data as of 4 Nov 2026, 16:44 UTC

CVSS 4.0 base score
6.9Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.06.9
CNA (VulnCheck)CVSS 3.16.5
Patch
Available – fixed in 0.0.23
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade easyVoice to 0.0.23.

Affected software

ProductAffectedFixed in
cosin2077easyVoiceAffected
  • <0.0.23
Fixed in
  • 0.0.23
GitHubeasyVoicepkg:github/easyVoiceOther threatsAffected
  • <0.0.23
Fixed in
  • 0.0.23

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Since the vulnerability affects versions before 0.0.23, upgrading to version 0.0.23 or later is implied as the remediation. Users should apply this update once available. Until then, restrict access to the vulnerable endpoints and monitor for suspicious activity.

Description

easyVoice versions before 0.0.23 have a server-side request forgery (SSRF) vulnerability. This flaw allows unauthenticated attackers to make the server send POST requests to internal or loopback services by manipulating the openaiBaseUrl parameter with useLLM enabled. Attackers can probe internal hosts and ports via the /api/v1/tts endpoint, leveraging reflected error messages in the x-generate-tts-warning header.

References

Community reviews

Loading reviews…