CVE-2026-44265: @enspirit/elo · Elo backends have code injection via unvalidated emission of programmatic AST fields
Affects @enspirit/eloSource GCVE Database
Not known to be exploited · CVSS 7.4 High : upgrade to 1.0.1 soon.
Data as of 3 Nov 2026, 19:28 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 3.1 | 7.4 |
|---|
- Patch
- Available – fixed in 1.0.1
CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 3 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.
What to do
Upgrade @enspirit/elo to 1.0.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| npm@enspirit/elo | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in version 1.0.1 of @enspirit/elo which adds runtime validation and escaping for all affected AST fields at the emit stage. Users should upgrade to version 1.0.1 or later to remediate this vulnerability. No other mitigations are indicated or required once patched. Avoid using untrusted or unauthenticated input to populate AST nodes until the patch is applied.
Description
CVE-2026-44265 is a code injection vulnerability in the @enspirit/elo library's programmatic AST API. The API accepts arbitrary values in many AST node fields without runtime validation, leading to unescaped interpolation into generated source code across JavaScript, Ruby, Python, and SQL backends. This allows attackers to inject arbitrary code or expressions, resulting in remote code execution or SQL injection. The issue affects all versions prior to 1.0.1 and was fixed in version 1.0.1. The vulnerability was verified with proof-of-concept exploits demonstrating code execution and SQL injection in all affected backends.
References
- github.com/enspirit/elo/security/advisories/GHSA-x9rp-7wh3-2rj5 (opens in a new tab)
- github.com/enspirit/elo/commit/d2a89a8db76a244eb740687524a7e8529b7554b5 (opens in a new tab)
- github.com/enspirit/elo/commit/fb57dd37a2669d9c412454225c5b89a2adba5d93 (opens in a new tab)
- github.com/enspirit/elo (opens in a new tab)