@enspirit/elo · Elo JavaScript emitter has sandbox escape to arbitrary Node.js / browser code execution via unfiltered `.constructor`
Affects @enspirit/eloSource GCVE Database
Not known to be exploited · CVSS 9.8 Critical : upgrade to 1.0.1 as a priority.
Data as of 3 Nov 2026, 19:28 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 3.1 | 9.8 |
|---|
- Patch
- Available – fixed in 1.0.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 3 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.
What to do
Upgrade @enspirit/elo to 1.0.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| npm@enspirit/elo | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in Elo version 1.0.1 that fixes the vulnerability by filtering dangerous property names such as `constructor`. Users should upgrade to version 1.0.1 or later to remediate this issue. Until patched, avoid running untrusted Elo code in any environment, including the CLI, library API, or browser playground. No other mitigations are indicated by the vendor advisory.
Description
A critical vulnerability in the Elo JavaScript emitter allows unauthenticated attackers to execute arbitrary code in the host JavaScript runtime. The flaw arises from unfiltered use of the `.constructor` property in Elo expressions, enabling sandbox escape and remote code execution (RCE) in Node.js and browser environments. This affects the Elo CLI, the browser playground at elo-lang.org, and the library API. The vulnerability is fixed in version 1.0.1.