Skip to main content
VulnerabilityPublished Updated

CVE-2025-54950: ExecuTorch out-of-bounds access vulnerability

Affects executorchSource GCVE Database

0
Authoritative record:CVE-2025-54950· Critical 9.8

Not known to be exploited · CVSS 9.8 Critical : upgrade to 0.7.0 as a priority.

Data as of 27 Oct 2026, 02:47 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 0.7.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 Aug 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade executorch and org.pytorch:executorch-android and github.com/pytorch/executorch to 0.7.0.

Affected software

ProductAffectedFixed in
PyPIexecutorchAffected
  • <0.7.0
Fixed in
  • 0.7.0
Mavenorg.pytorch:executorch-androidAffected
  • <0.7.0
Fixed in
  • 0.7.0
SwiftURLgithub.com/pytorch/executorchAffected
  • <0.7.0
Fixed in
  • 0.7.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade ExecuTorch to version 0.7.0 or later to apply the official fix. Since a patch is available, applying this update will remediate the vulnerability. No additional vendor advisory indicates other mitigations or that no action is required.

Description

An out-of-bounds access vulnerability in ExecuTorch versions prior to 0.7.0 can cause the runtime to crash and may lead to code execution or other harmful effects. This critical vulnerability is identified as CVE-2025-54950 and has a high CVSS score of 9.8. The issue is fixed in version 0.7.0.

References

Community reviews

Loading reviews…