Skip to main content
VulnerabilityPublished

kimi-cli · FastMCP: Post-transform component authorization is skipped on direct calls

Affects kimi-cliSource GCVE Database

0

CVSS 6.8 Medium.

Data as of 26 Oct 2026, 19:42 UTC

CVSS 3.1 base score
6.8Medium
How severe the flaw is on the 0–10 CVSS scale.
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N

What to do

Affected software

ProductAffectedFixed in
Homebrewkimi-clipkg:brew/kimi-cliOther threatsAffected
  • >=1.44.0
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrading to FastMCP versions 3.4.10 or 4.1.2 or later resolves the issue by enforcing authorization on the final transformed component. Until upgrading, avoid configurations with overlapping proxy templates for protected resources and enforce authorization at the handler or server boundary rather than relying solely on component policies affected by transforms.

Description

FastMCP versions 3.0.0 through 3.4.9 and 4.0.0 through 4.1.1 contain an authorization bypass vulnerability where direct calls to transformed components skip the final authorization check. This allows low-privilege users to invoke protected tools, resources, templates, or prompts that should be denied. The issue arises because the server applies transforms before authorization but does not re-check the authorization on the transformed component in direct lookup paths. Fixes are available in FastMCP 3.4.10 and 4.1.2.

References

Community reviews

Loading reviews…