Skip to main content
VulnerabilityPublished Updated

CVE-2026-52296: libav · FFmpeg before 9.0 has an out-of-bounds read because of missing required padding in WMA extradata allocation paths in libavcodec/wmaenc.c

Affects libavSource GCVE Database

0
Compare

Not known to be exploited · CVSS 7.1 High : upgrade to 9.0 soon.

Data as of 29 Oct 2026, 10:10 UTC

CVSS 3.1 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 4% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.0
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade ffmpeg/FFmpeg to 9.0.

Affected software

ProductAffectedFixed in
GitHubffmpeg/FFmpegpkg:github/ffmpeg/FFmpegOther threatsAffected
  • <9.0
Fixed in
  • 9.0
Ubuntu Pro 14.04 LTSlibavpkg:deb/ubuntu/libav?arch=source&distro=esm-infra-legacy/trustyOther threatsAffected
  • 6:0.8.7-1ubuntu2 – 6:9.20-0ubuntu0.14.04.1+esm1
14 affected builds
Fixed in–
Ubuntu Pro 16.04 LTSffmpegpkg:deb/ubuntu/ffmpeg?arch=source&distro=esm-apps-legacy/xenialOther threatsAffected
  • 7:2.7.2-1build1 – 7:2.8.17-0ubuntu0.1+esm18
36 affected builds
Fixed in–
Ubuntu Pro 18.04 LTSffmpegpkg:deb/ubuntu/ffmpeg?arch=source&distro=esm-apps/bionicOther threatsAffected
  • 7:3.3.4-2 – 7:3.4.11-0ubuntu0.1+esm16
30 affected builds
Fixed in–
Ubuntu Pro 20.04 LTSffmpegpkg:deb/ubuntu/ffmpeg?arch=source&distro=esm-apps/focalOther threatsAffected
  • 7:4.1.4-1build2 – 7:4.2.7-0ubuntu0.1+esm18
26 affected builds
Fixed in–
Ubuntu Pro 22.04 LTSffmpegpkg:deb/ubuntu/ffmpeg?arch=source&distro=esm-apps/jammyOther threatsAffected
  • 7:4.4-6ubuntu5 – 7:4.4.2-0ubuntu0.22.04.1+esm17
24 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Until a fix is confirmed, avoid processing untrusted WMA media files or use updated FFmpeg versions if available.

Description

FFmpeg versions prior to 9.0 have an out-of-bounds read vulnerability in the WMA extradata allocation paths within libavcodec/wmaenc.c due to missing required padding. This flaw can cause a denial of service but does not affect confidentiality or integrity.

References

Community reviews

Loading reviews…