CVE-2026-70631: Libav · FFmpeg versions from 0.5 up to, but not including, 9.0 contain an uninitialized heap memory disclosure vulnerability in the native TIFF decoder in
Affects libavSource GCVE Database
Not known to be exploited · CVSS 5.5 Medium · fixed in 9.0 : update libav when convenient.
Data as of 5 Nov 2026, 23:24 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 7% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 9.0, 7:4.2.7-0ubuntu0.1+esm17, 7:4.4.2-0ubuntu0.22.04.1+esm16
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 6 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Upgrade ffmpeg/FFmpeg to 9.0; the Ubuntu ffmpeg package to 7:4.2.7-0ubuntu0.1+esm17; the Ubuntu ffmpeg package to 7:4.4.2-0ubuntu0.22.04.1+esm16.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHubffmpeg/FFmpegpkg:github/ffmpeg/FFmpegOther threats | Affected
| Fixed in
|
Ubuntu Pro 14.04 LTSlibavpkg:deb/ubuntu/libav?arch=source&distro=esm-infra-legacy/trustyOther threats | Affected
| Fixed in– |
Ubuntu Pro 16.04 LTSffmpegpkg:deb/ubuntu/ffmpeg?arch=source&distro=esm-apps-legacy/xenialOther threats | Affected
| Fixed in– |
Ubuntu Pro 18.04 LTSffmpegpkg:deb/ubuntu/ffmpeg?arch=source&distro=esm-apps/bionicOther threats | Affected
| Fixed in– |
Ubuntu Pro 20.04 LTSffmpegpkg:deb/ubuntu/ffmpeg?arch=source&distro=esm-apps/focalOther threats | Affected
| Fixed in
|
Ubuntu Pro 22.04 LTSffmpegpkg:deb/ubuntu/ffmpeg?arch=source&distro=esm-apps/jammyOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available for this vulnerability. Users and administrators should apply the official updates to FFmpeg versions to versions 9.0 or later where this issue is fixed. No additional mitigations are specified by the vendor advisory.
Description
FFmpeg versions from 0.5 up to, but not including, 9.0 contain an uninitialized heap memory disclosure vulnerability in the native TIFF decoder. This vulnerability allows an attacker who can supply a crafted TIFF file with a valid Deflate-compressed strip that decompresses fewer bytes than declared to cause stale heap data to be included in the decoded image output, potentially exposing sensitive data. The vulnerability has a medium severity with a CVSS score of 5.5. A patch is available to address this issue.
References
- nvd.nist.gov/vuln/detail/CVE-2026-70631 (opens in a new tab)
- code.ffmpeg.org/FFmpeg/FFmpeg/commit/2f234ea34c81288e3840fca632dd16481d8de39f (opens in a new tab)
- code.ffmpeg.org/FFmpeg/FFmpeg/commit/3c287af3affe1286350faa69c02bcc5d49de18bb (opens in a new tab)
- code.ffmpeg.org/FFmpeg/FFmpeg/commit/a991b1fecbd8c9e6f4fc31c191bd12e4be27dbf7 (opens in a new tab)
- code.ffmpeg.org/FFmpeg/FFmpeg/pulls/23899 (opens in a new tab)
- vulncheck.com/advisories/ffmpeg-uninitialized-heap-memory-read-in-tiff-decoder (opens in a new tab)
- ubuntu.com/security/CVE-2026-70631 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-70631 (opens in a new tab)
- ubuntu.com/security/notices/USN-8750-1 (opens in a new tab)