CVE-2026-70629: Libav · FFmpeg versions from 3.0 up to, but not including, 9.0 contain an uninitialized heap memory read vulnerability in the native RSCC decoder
Affects libavSource GCVE Database
Not known to be exploited · CVSS 5.5 Medium · fixed in 9.0 : update libav when convenient.
Data as of 5 Nov 2026, 23:24 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 7% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 9.0, 7:4.2.7-0ubuntu0.1+esm17, 7:4.4.2-0ubuntu0.22.04.1+esm16
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 6 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Upgrade ffmpeg/FFmpeg to 9.0; the Ubuntu ffmpeg package to 7:4.2.7-0ubuntu0.1+esm17; the Ubuntu ffmpeg package to 7:4.4.2-0ubuntu0.22.04.1+esm16.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHubffmpeg/FFmpegpkg:github/ffmpeg/FFmpegOther threats | Affected
| Fixed in
|
Ubuntu Pro 14.04 LTSlibavpkg:deb/ubuntu/libav?arch=source&distro=esm-infra-legacy/trustyOther threats | Affected
| Fixed in– |
Ubuntu Pro 16.04 LTSffmpegpkg:deb/ubuntu/ffmpeg?arch=source&distro=esm-apps-legacy/xenialOther threats | Affected
| Fixed in– |
Ubuntu Pro 18.04 LTSffmpegpkg:deb/ubuntu/ffmpeg?arch=source&distro=esm-apps/bionicOther threats | Affected
| Fixed in– |
Ubuntu Pro 20.04 LTSffmpegpkg:deb/ubuntu/ffmpeg?arch=source&distro=esm-apps/focalOther threats | Affected
| Fixed in
|
Ubuntu Pro 22.04 LTSffmpegpkg:deb/ubuntu/ffmpeg?arch=source&distro=esm-apps/jammyOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available for this vulnerability. Users should apply the official fixes provided by the FFmpeg or libav maintainers to versions 9.0 or later where this issue is resolved. No additional mitigation steps are indicated by the vendor advisory.
Description
FFmpeg versions from 3.0 up to, but not including, 9.0 contain an uninitialized heap memory read vulnerability in the native RSCC decoder. This vulnerability allows an attacker to disclose heap memory contents by providing a crafted video file with a compressed tile that decompresses fewer bytes than expected. The flaw occurs because the decompressed byte count is not validated against the tile dimensions before copying data, potentially exposing data from prior heap allocations or previously decoded frames. The vulnerability has a CVSS 3.1 score of 5.5 (medium severity). A patch is available for this issue.
References
- nvd.nist.gov/vuln/detail/CVE-2026-70629 (opens in a new tab)
- code.ffmpeg.org/FFmpeg/FFmpeg/commit/533a6198505edd1379e1cd722852350ae4a85acc (opens in a new tab)
- code.ffmpeg.org/FFmpeg/FFmpeg/commit/a5fe21a1a410a680fe93c33b0dd696b7e1c3aea4 (opens in a new tab)
- code.ffmpeg.org/FFmpeg/FFmpeg/commit/cd1f545cf27ba08f6f5b31b1e92665d7874d4fd7 (opens in a new tab)
- code.ffmpeg.org/FFmpeg/FFmpeg/pulls/23895 (opens in a new tab)
- vulncheck.com/advisories/ffmpeg-uninitialized-heap-memory-read-in-rscc-decoder (opens in a new tab)
- ubuntu.com/security/CVE-2026-70629 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-70629 (opens in a new tab)
- ubuntu.com/security/notices/USN-8750-1 (opens in a new tab)